1

I learned about using :profile here, so I just tried to install vim with profiling enabled.

I tried this:

./configure --prefix=/home/username --with-features=profile

But in the output from configure I got the message

Sorry, profile is not supported

Does that mean that profile is not an option for me at all because of my OS, or is there something that I can do to make it "supported"?

3
  • Perhaps Vim can't find libperl.so and skips it because of that? You should post at least the full output of vim --version (has linker command) and preferable also the full output of ./configure and make... You should have something like -L/usr/lib/perl5/core_perl/CORE -lperl in there. – Martin Tournoij Mar 10 '15 at 14:07
  • @Carpetsmoker You're right. That is missing. Thanks! – Christopher Bottoms Mar 10 '15 at 14:17
  • @Carpetsmoker Thanks. I didn't think to look in the middle of the configure output before your comment. I updated the question to focus on getting profile enabled (a necessity for me) and perl is more of a want. – Christopher Bottoms Mar 10 '15 at 14:25
5

I don't think you can enable the profile feature via ./configure; you either have to define FEAT_PROFILE or simply build a huge version of Vim, which then includes that feature. From src/feature.h:

/*
* +profile      Profiling for functions and scripts.
*/
#if defined(FEAT_HUGE) \
        && defined(FEAT_EVAL) \
        && ((defined(HAVE_GETTIMEOFDAY) && defined(HAVE_SYS_TIME_H)) \
                || defined(WIN3264))
# define FEAT_PROFILE
#endif

TL;DR

./configure --with-features=huge
2

--with-features=profile doesn't seem to be valid option; :help profile says:

The +profile feature is required for this. It is only included when Vim was compiled with "huge" features.

So use:

$ ./configure --with-features=huge

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.