0

In the case below, how would I find what the definition of [cmd] or [range] or {pattern} is ?

enter image description here

I have tried CTRL-] with my cursor on these, but this does not do anything.

  • CTRL-] works on [range], pattern is :h pattern, cmd is any :commad vim has (probably any?) – Maxim Kim Apr 12 at 11:05
  • I am a using neovim. When I put the cursor on the first [range] in the screenshot , inside :[range]g[lobal]/{pattern}/[cmd] I get error E149: Sorry, no help for: :[range]g[lobal]/{pattern}/[cmd]. However when I put the cursor on the second [range] in the screenshot , the one in the description, CTRL-] does work ! Pressing CTRL-] on the second [cmd] in the screenshot takes me to a random place in the help system, whilst i get the same error as for [range] for the first. – user3203476 Apr 12 at 12:38
  • first range is a part of a longer word :[range]g[lobal]/{pattern}/[cmd] and there is no such help tag. – Maxim Kim Apr 12 at 12:54
2

CTRL-] jump is tag based, meaning that it will take word under cursor and jump to the first tag matching it.

somewhere in :help help and /Jump to speci<CR>

Jump to specific subjects by using tags.  This can be done in two ways:
- Use the "CTRL-]" command while standing on the name of a command or option.
  This only works when the tag is a keyword.  "<C-Leftmouse>" and
  "g<LeftMouse>" work just like "CTRL-]".
- use the ":ta {subject}" command.  This also works with non-keyword
  characters.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.