The tar.vim plugin tries to give a special view of tar files. Its filetype "detection" matches against the filename.

If I try to download a tar file from the web and get an HTML error page, I cannot open it in vim without first renaming the file. Vim instead shows me tar.vim's error output ("gzip: file not in gzip format, tar: this does not look like a tar archive"), and I cannot seem to switch to editing as a regular file.

Is there a command line option to disable the tar.vim plugin, or filetype detection? I don't want to have to temporarily edit my .vimrc or rename the file (I want to overwrite it with the archive once I figure out the problem).



Browse other questions tagged or ask your own question.