0

I just started using vim. As I understand it, using a plugin manager is the easiest way of installing plugins for vim. So I thought I would try vim-plug which I installed using curl as explained here. Then I looked for plugins on vimawesome and I thought I would try to install solarized colors. I just put this in my .vimrc

call plug#begin()
Plug 'altercation/vim-colors-solarized'
call plug#end()

then I opened vim and did PlugInstall and PlugUpdate but when I open a new vim I don't get the solarized colors. What am I doing wrong?

Edit

I tried the suggestion but when I type :colorscheme solarized I get the following enter image description here

2
  • 2
    fancy colorschemes use colors unavailable for terminals, unless you prepare it by providing color palette or if terminal supports termguicolors option. Thus, first of all try :set termguicolors and then :colo solarized.
    – Maxim Kim
    Mar 20 '20 at 18:11
  • 2
    And if you go to the URL you show us there is a BIG section IMPORTANT NOTE FOR TERMINAL USERS: you should read.
    – Maxim Kim
    Mar 20 '20 at 18:13
2

You need to load it. Add colorscheme solarized to your .vimrc. You can also load it on the fly executing :colorscheme solarized on the Vim command line

3
  • When I try the suggestion I get something as I printed above which doesn't seem right
    – roi_saumon
    Mar 20 '20 at 17:37
  • @roi_saumon you need to enable termguicolors with set termguicolors and use a terminal emulator that supports them. I think on Linux most terminal emulators do, on macOS you can try iTerm2 or (my favourite) Kitty
    – Tae
    Mar 20 '20 at 19:15
  • 1
    Alacritty also @Tae. But it's not completely necessary if you happen to like Terminal.app or tmux, and you set up your term's color palette correctly.
    – D. Ben Knoble
    Mar 20 '20 at 22:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.