1

When I start vim on my Mac using iterm or MacVim I receive the following error message:

E575: viminfo: Illegal starting char in line: ^A<ce>^Y^C<f1>H<85><a9>generator<c4>^Dnvim<a7>version<c4>^KNVIM v0.4.3<a9>max_kbyte
E575: viminfo: Illegal starting char in line: <a3>pid<cd>^I^Q<a8>encoding<c4>^Eutf-8^C
E575: viminfo: Illegal starting char in line: <ce>^X^I<86>I<83><a1>f<c4>>/usr/local/Cellar/neovim/0.4.3/share/nvim/runtime/doc/nvim.txt<a1>l^G<a1>c^N^D<ce>^W<b6><d9>^M<92>
Press ENTER or type command to continue 

But when I press ENTER vim starts. I have deleted .viminfo file at the home folder. I suspect that it has something to do with neovimbut I am not sure.

4
  • Does your vimrc override the location of the viminfo file? What does :set viminfofile? return? Does the problem happen if you start Vim with vim -i NONE? Or vim -i ~/.viminfo?
    – filbranden
    Feb 28 '20 at 13:22
  • 1
    :set viminfofile returns viminfofile=. And when I start Vim with vim -i NONE or vim -i ~/.viminfo the problem doesn't happen.
    – sbac
    Feb 28 '20 at 16:43
  • 1
    @filbranden Yes, vimrc set the location of viminfo file in ' ~/.vim/dirs'. I deleted viminfo and now everything seems fine.
    – sbac
    Feb 28 '20 at 19:56
  • 1
    Please post an answer with what fixed it for you. If possible, include the snippet in your vimrc that was setting the path to the viminfo file. Thanks!
    – filbranden
    Feb 28 '20 at 20:04
1

In the vimrc file the following snippet overrides the location of the viminfo file from the home folder to ~/.vim/dirs folder:

set viminfo+=n~/.vim/dirs/viminfo

So, deleting the viminfofile in this folder solves this error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.