0

I am trying to get the plugin vim-matlab for neovim working, but with no success. When I try to call any command from nvim ( like :MatlabCliHelp ), I get the following output. Do you have any ideas what I am doing wrong? Thank you for your answers

Error detected while processing function remote#define#CommandBootstrap[5]..remote#define#request:
line    2:                                                                                                                                                                                        
error caught in request handler '/home/kuntik/.config/nvim/bundle/vim-matlab/rplugin/python/vim_matlab:command:MatlabCliHelp ()':
Traceback (most recent call last):
  File "/home/kuntik/.config/nvim/bundle/vim-matlab/rplugin/python/vim_matlab/__init__.py", line 121, in matlab_cli_help
    self.activate_cli()
  File "/home/kuntik/.config/nvim/bundle/vim-matlab/rplugin/python/vim_matlab/__init__.py", line 81, in activate_cli
    self.cli_controller = MatlabCliController()
  File "/home/kuntik/.config/nvim/bundle/vim-matlab/rplugin/python/vim_matlab/matlab_cli_controller.py", line 16, in __init__
    self.connect_to_server()
  File "/home/kuntik/.config/nvim/bundle/vim-matlab/rplugin/python/vim_matlab/matlab_cli_controller.py", line 20, in connect_to_server
    self.sock.connect((self.host, self.port))
  File "/usr/lib/python2.7/socket.py", line 228, in meth
    return getattr(self._sock,name)(*args)
error: [Errno 111] Connection refused
0

It's trying to connect to the server, but it looks like the server just isn't running...

See the plug-in's usage, which tells you how you need to start the server first, with:

./scripts/vim-matlab-server.py

From the README file:

This will start a Matlab REPL and redirect commands received from Vim to Matlab. When Matlab crashes (e.g. segfault during MEX development), it will launch another process.

Then open Vim in another terminal and start editing .m files.

Alternatively, launch a server instance from Vim using :MatlabLaunchServer. The server will be launched either in a Neovim terminal buffer or a tmux split (see g:matlab_server_launcher).

So starting it with a :MatlabLaunchServer command seems to be an option too.

1
  • 1
    It seems I had isue with automatic installation ( all scripts that supposed to be installed were missing). That is probably the reason why :MatalbLaunchServer command is missing in my neovim. Anyway I fixed the problem with maualy adding scripts to my scripts folder. Thank you for your time. – lukáš Kunt Feb 25 '20 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.