3

I seem to have messed with some settings which have resulted in the area where I enter commands now being 2 characters in height. See the screenshot below:

vim-command-entry-form

What do I have to set in my init.vim file (I am using Neovim) to return this area to being 1 character in height?

  • 1
    @filbranden that seems to have done the trick. I had recently installed the coc.nvim plugin and lifted the configuration for it from the repo and it seems one of the things that this changes is cmdheight. If you want to write your comment up up as an answer I'd be glad to accept. Thanks! – seeker Feb 17 at 17:56
3

It's possible that this is caused by the 'cmdheight' option, which configures the number of screen lines to use for the command-line.

You can reset it to its default of 1 with:

:set cmdheight&

Since the default is to keep just one row for the command-line, it's possible you got this configured in your vimrc, so just removing it from there should solve the issue for you.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.