1

I faced an issueenter image description here As you can see on the screenshot, vim does not show tabs with specified airline theme and it shows me this annoying X button at the end of the tabline. Here's my .vimrc:

execute pathogen#infect()
syntax on
filetype plugin indent on

"Theme Section
colo minimalist
let g:airline_theme='minimalist'
let g:airline_powerline_fonts = 1
let g:airline#extensions#tabline#enabled = 1
let g:airline#extensions#tabline#show_close_button = 0
set nu

I've created another tab: enter image description here If I go back to the previous one, my airline theme resets to the default one: enter image description here And if I switch to the new tab, this default theme stays and annoys me. But, here's some magic:enter image description here If I open a directory using vim, airline themed tabline seems to be working. enter image description here When I switch tabs, airline tabline theme resets again:enter image description here Help me, please.

  • This seems like a serious bug. What version of airline are you using? What version of vim? Is there other code (~/.vim) that could be interfering? Autocommands, etc.? – D. Ben Knoble Jan 27 at 21:56
  • @D.BenKnoble no, my .vimrc contains only those several lines of code, nothing else. vim version is 8.2.0148-1, vim-airline 0.10-1, vim-airline-themes r1321.3bfe1d0-1. – Me. Jan 27 at 22:35
0

Setting everything up with Vundle (instead of Pathogen) fixed the bug. Now everything works! enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.