0

I am trying to configure TabNine and Intelephense with coc.

I like the autosuggestions offered by TabNine. But Intelephense plugin is enabled, I am seeing suggestions from only Intelephense and not TabNine (probably because Intelephense is much faster).

I want to use TabNine for autocompletion, but continue to use the other features of Intelephense engine like validation, function signature overlay, go to definition etc.

How can I turn off the autocomplete feature of Intelephense, or prioritize TabNine over Intelephense?

0

Managed to do this by setting intelephense.completionProvider.maxItems to 0 in coc-settings.json

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.