1

I'm using vim for writing LaTeX documents. I also have vim-latex installed. While I'm writing my documents in the editor, I get ligatures for that piece of text which is meaningful for the LaTeX language. For example, when I type an en-dash as defined by the language (--), I get a continuous dash line which is the size of two consecutive dashes, instead. I don't find this feature helpful and sometimes even confusing. So I want to see the document as it is while I'm using the editor. Is there any option to set this feature off?

3

This is a part of standard filetype plugin, see :h tex.vim for a complete info.

That particular feature is controlled by :h g:tex_conceal

So it's enough to add let g:tex_conceal = '' to your vimrc (or to disable only ligatures and accents: let g:tex_conceal = 'dmgs', i.e. no 'a' in tex_conceal's value).

| improve this answer | |
  • 2
    So the technical term for this feature is concealing. That's maybe why I couldn't find anything relevant to my problem. I didn't know what it is called in vim. Thanks for the answer. – Saeed Ahadian Jan 2 at 10:09
  • 1
    Also let g:tex_conceal = 'bdmgs' should have b because otherwise, it would also conceal bold and italics. – Saeed Ahadian Jan 2 at 10:12
  • 1
    Also you can turn off conceal by setting conceallevel, but that’s the big hammer where Matt gives the little hammer – D. Ben Knoble Jan 2 at 14:24
  • @D.BenKnoble Yes, conceal in Vim is a general feature not confined to TeX. Notably, it's used by indentLines / vim-indent-guides and, perhaps, some other plugins. Fully disabling it is possible, but shouldn't be generally recommended. – Matt Jan 2 at 14:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.