I have a plugin that only has install instructions for NeoBundle. I primarily use Plug, however. I tried copying the GitHub path from the NeoBundle instructions to a Plug command considering the two are set up similarly, but Plug will not let it install. Do I need to run both Plug and NeoBundle, or is there a way to run NeoBundle plugins in Plug?

In particular, I'd like to use plugin vim-nerdtree-syntax-highlight, which lists as install instructions:

NeoBundle 'tiagofumo/vim-nerdtree-syntax-highlight'

1 Answer 1


You can install this plug-in using vim-plug. Just use vim-plug's command for it:

Plug 'tiagofumo/vim-nerdtree-syntax-highlight'

NeoBundle is a fork of Vundle and vim-plug is a successor of Vundle. This lineage means they share commonalities in managing plugins and they are fairly compatible with each other.

All of Vundle, NeoBundle and vim-plug use very similar way of setting up plugins, with a stanza in the vimrc file delimited by calls to a vundle#begin() and a vundle#end() (or neobundle, or plug), having the list of plugins to load/install listed inside that block, using a command registered by the plugin itself.

Most differences between these three are in how they manage installing and fetching plugins, but mainly in how the newer ones try to fetch plugins using more parallelism and asynchronous calls in order to provide faster install/update processes.

In terms of plugin layout, virtually all Vim plugins use the same layout, which was initially proposed by tpope's pathogen.vim (and can even be traced further back to vimball packages), which involves shipping the plugin files in the subdirectories recognized by Vim inside ~/.vim or vimfiles or $VIMRUNTIME, and then using the 'runtimepath' option to include all the plugin directories, so that their files will be found by Vim during runtime.

(In fact, this process of registering plugins into 'runtimepath' was made into a first class feature of Vim 8, which introduced support for "packages" which implement this same procedure.)

  • when I run that and :PlugInstall I get: fatal: could not read Username for 'https://GitHub.com': terminal prompts disabled
    – amyiris
    Commented Dec 20, 2019 at 15:41
  • 1
    @ProgrammerPlays That usually indicates you have a typo in the name of the plug-in repo... Can you double check that you have it right? Copy and paste from my answer if necessary (the one you mentioned in your comments had a few typos on it.)
    – filbranden
    Commented Dec 20, 2019 at 15:55
  • 1
    Thank you! That worked.
    – amyiris
    Commented Dec 20, 2019 at 16:12
  • 2
    @filbranden thank you for always taking the extra steps to explain the background!!
    – guntbert
    Commented Dec 20, 2019 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.