2

Here is my .vimrc file:

set encoding=utf-8
scriptencoding utf-8
set list
set listchars=tab:→·

When I open vim, it will show an error message E474: Invalid argument: listchars=tab:→·

My vim is Vi IMproved 8.1 Huge version without GUI and the multi_lang feature is enabled. I don't know why it doesn't support special characters →·.


Edit

Thanks Christian Brabandt for pointing my error that tab need two characters. However, when I set tab to →·, it still didn't work. And finally, I find that this problem is caused by XShell because this configuration works well under GNOME. After changing the XShell Terminal Type to linux or ansi instead of xterm, it works! But if I change it back, it still works. I don't know why. Maybe it's a bug.

  • 3
    the tab suboption of the listchars settings needs two characters! – Christian Brabandt Dec 17 '19 at 13:18
  • @ChristianBrabandt Thanks, but it still didn't work. The question has been updated. – haolee Dec 17 '19 at 13:45
  • what's the output of locale? – D. Ben Knoble Feb 26 at 19:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.