2

Editing a Qt localization file, which actually is a XML. I'd like to check spelling for a text inside tags, so executed a command setlocal spell spelllang=fr After that only attribute value become highlighted as wrong in the first line as you can see on the screen shot.

How to make this work as expected?

screen shot

Update: Works with vim 8.2.0076.

  • It works for me for english and russian. What is your vim version, what is filetype? Did you download french spell files? – Maxim Kim Dec 10 '19 at 10:43
  • @MaximKim, Vim version is 8.1 (2018 May 18) Included patches: 1-2372. My editor detects this TS file based on extension as TYPESCRIPT, so I swith to XML filetype manually with set filetype=xml, but this does not help. – taro Dec 11 '19 at 11:37
  • I use the latest 8.1.2418 and for me it works. Are you sure you have downloaded french spell file? – Maxim Kim Dec 11 '19 at 11:51
  • just to dblcheck you have fixed xml.vim, open it with :find $VIMRUNTIME/**/syntax/xml.vim and check if there is syn spell toplevel on line 60. – Maxim Kim Dec 11 '19 at 11:56
6

Spellchecking inside tags has been requested some time ago (and apparently was a long outstanding Debian wishlist bug) and was enabled in the vim-xml syntax file since this commit. Just clone the runtime files inside your package directory and it should readily work.

The soon to be awaited Vim 8.2 release already contains this commit and should then work as expected.

  • It is already available for windows builds github.com/vim/vim-win32-installer/releases, btw :) – Maxim Kim Dec 11 '19 at 11:58
  • aaand I found your name there, so you know that of course. Thanks for providing daily vim builds! – Maxim Kim Dec 11 '19 at 12:01
  • @taro If this answer answers your question please make sure to mark it as accepted using the accept button under the downvote button. This will help future users to know that the answer worked for you and they can use it too. And if that doesn't answer your question please add details on what you are missing. – statox Dec 11 '19 at 13:10
  • @MaximKim thanks for the nice words :) – Christian Brabandt Dec 11 '19 at 14:01
  • Upgraded vim to version 8.2 and it works as needed. Thank you! – taro Jan 4 at 10:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.