1

I am relatively new to vim and tried to understand this article and also read :help guicursor and inserted this line in my .vimrc

set guicursor+=a:-blinkwait175-blinkoff150-blinkon175

But it didn't do anything. What is the problem here?

PS: Sorry if I have to be spoon-fed. VIM is kinda intimidating for me right now.

Edit: I need it for the terminal VIM and not gVIM, so the mentioned method won't work I realised that right now. But what will?

2
  • What you expect and what you get instead? BTW, do you use gVim or terminal vim?
    – Maxim Kim
    Nov 14, 2019 at 9:17
  • What terminal do you use? Find it out and then search for the way to change it there. For example, askubuntu.com/a/485489/68235 is for gnome-terminal.
    – Maxim Kim
    Nov 14, 2019 at 12:48

2 Answers 2

2

Every strange question have quite simple answers. Refer this thread. All that I had to do was enable cursor blinking in the terminal preference itself :/

0

The issue probably is that you don't use highlight group for the cursor you define.

See pic:

enter image description here

This is for GUI vim, not sure how it should be applied to terminal one.

9
  • I need it for the terminal vim :/
    – sh.3.ll
    Nov 14, 2019 at 10:22
  • then this shouldn't be guicursor: {only available when compiled with GUI enabled, and for MS-DOS and Win32 console}
    – Maxim Kim
    Nov 14, 2019 at 10:26
  • Then how to do it for terminal vim?
    – sh.3.ll
    Nov 14, 2019 at 10:28
  • I think you have to consult your terminal documentation.
    – Maxim Kim
    Nov 14, 2019 at 11:24
  • You can't control it from within vim I think. Each terminal probably has different way to change it, for example gnome-termial of some version of gnome might use askubuntu.com/a/485489/68235
    – Maxim Kim
    Nov 14, 2019 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.