2

When using CoC.nvim's suggestion list, I often find myself pressing Esc twice to return to normal mode - once for cancelling CoC's list session and once to actually exit insert mode. I find that extraneous (and noisy, considering I'm using a clicky mechanical keyboard in an open office).

I checked CoC's documentation but could not find anything that would solve this with configuration.

What is a good, maintainable way of having Esc close CoC's list session and exit insert mode with one press?

  • 2
    That's weird what you describe here seems to be the default behavior for me (in neovim and vim both with coc completion or with the default completion). Do you use a custom configuration to show coc completions or do you use the built-in pop up menu? – statox Oct 31 '19 at 10:04
  • @statox Nope, the only thing I have in my coc-settings.json file is the configuration for a language server. Maybe I'll try to do a fresh install of CoC to see what happens. – Christian Oct 31 '19 at 13:46
1

It turns out it was another plugin causing the interference: townk/vim-autoclose. After uninstalling it, the issue went away.

I am now using jiangmiao/auto-pairs without problems.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.