0

I am trying to setup fzf and use it with vim, tried to follow the instructions in the git repo but could not get things to work.

I was successfully able to install fzf and use the :FZF command in vim. Then I tried to install the fzf wrapper plugin here https://github.com/junegunn/fzf.vim and could not get it to work.

None of the commands are found when I run them inside vim, for example :Ag returns a command not found error but :FZF works fine.

This is my vimrc:

set nocompatible              " be iMproved, required
filetype off                  " required

" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()
" alternatively, pass a path where Vundle should install plugins
"call vundle#begin('~/some/path/here')

" let Vundle manage Vundle, required
Plugin 'VundleVim/Vundle.vim'

Plugin 'junegunn/fzf', { 'dir': '~/.fzf', 'do': './install --all' }

Plugin 'junegunn/fzf.vim'

" All of your Plugins must be added before the following line
call vundle#end()            " required
filetype plugin indent on    " required
" To ignore plugin indent changes, instead use:
"filetype plugin on
"
" Brief help
" :PluginList       - lists configured plugins
" :PluginInstall    - installs plugins; append `!` to update or just :PluginUpdate
" :PluginSearch foo - searches for foo; append `!` to refresh local cache
" :PluginClean      - confirms removal of unused plugins; append `!` to auto-approve removal
"
" see :h vundle for more details or wiki for FAQ
" Put your non-Plugin stuff after this line
syntax on
set tabstop=2

This is the output of :scriptnames in vim:

  1: /usr/share/vim/vimrc
  2: ~/.vimrc
  3: /usr/share/vim/vim80/ftoff.vim
  4: ~/.vim/bundle/Vundle.vim/autoload/vundle.vim
  5: ~/.vim/bundle/Vundle.vim/autoload/vundle/config.vim
  6: /usr/share/vim/vim80/filetype.vim
  7: /usr/share/vim/vim80/ftplugin.vim
  8: /usr/share/vim/vim80/indent.vim
  9: /usr/share/vim/vim80/syntax/syntax.vim
 10: /usr/share/vim/vim80/syntax/synload.vim
 11: /usr/share/vim/vim80/syntax/syncolor.vim
 12: ~/.vim/bundle/fzf.vim/plugin/fzf.vim
 13: /usr/share/vim/vim80/plugin/getscriptPlugin.vim
 14: /usr/share/vim/vim80/plugin/gzip.vim
 15: /usr/share/vim/vim80/plugin/logiPat.vim
 16: /usr/share/vim/vim80/plugin/manpager.vim
 17: /usr/share/vim/vim80/plugin/matchparen.vim
 18: /usr/share/vim/vim80/plugin/netrwPlugin.vim
 19: /usr/share/vim/vim80/plugin/rrhelper.vim
 20: /usr/share/vim/vim80/plugin/spellfile.vim
 21: /usr/share/vim/vim80/plugin/tarPlugin.vim
 22: /usr/share/vim/vim80/plugin/tohtml.vim
 23: /usr/share/vim/vim80/plugin/vimballPlugin.vim
 24: /usr/share/vim/vim80/plugin/zipPlugin.vim
 25: /usr/share/vim/vim80/scripts.vim
 26: /usr/share/vim/vim80/ftplugin/vim.vim
 27: /usr/share/vim/vim80/indent/vim.vim
 28: /usr/share/vim/vim80/syntax/vim.vim
 29: /usr/share/vim/vim80/syntax/ruby.vim
 30: /usr/share/vim/vim80/syntax/python.vim
 31: ~/.vim/bundle/Vundle.vim/autoload/vundle/installer.vim
 32: ~/.vim/bundle/Vundle.vim/autoload/vundle/scripts.vim
 33: ~/.vim/bundle/fzf/plugin/fzf.vim
 34: ~/.vim/bundle/fzf.vim/autoload/fzf/vim.vim

What seems weird is that there is ~/.vim/bundle/fzf/plugin/fzf.vim and ~/.vim/bundle/fzf.vim/plugin/fzf.vim.

Any help would be really appreciated!

  • do you have fzf and ag executables installed? – Maxim Kim Oct 29 at 9:25
  • Welcome to Vi and Vim! Ag requires that ag is installed... – D. Ben Knoble Oct 29 at 12:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.