1

I'm trying to install this colorscheme. They instructed to use a package manager so I've used vim-plugged:

Plug 'rakr/vim-one'

While my colours on vim did change, it really does not look like the colorscheme screenshot.

Let me just mention that I'm a noob to vim and I tweaked it a lot recently, in order to understand this environment. Among other things I did, I also installed the amix config, but removed it. I tried to undo all my configurations, I don't know if I've completely succeeded in doing so. I wanted to uninstall vim so I could fresh start, but did not find on Google how to properly uninstall vim, so I brew reinstalled it. I still don't think it reseted everything.

I'm on iTerm 2 on a Mac OS.

My .vimrc.

  • Try adding set termguicolors to your .vimrc file. Also, are you using Vim inside tmux or screen or similar? – filbranden Oct 26 '19 at 8:48
  • @filbranden I think the set termguicolors solved it, many thanks! How can I mark this comment as an answer? By the way, the font I see in the screenshot I mentioned should also come with the colorscheme, or is there another way to install fonts? – idankor Oct 26 '19 at 9:03
  • Only GVim/MacVim can set a font (set guifont=xxx); Vim simply uses what is preset by your terminal. Also, you are always allowed to answer your question yourself and accept it. – Matt Oct 26 '19 at 9:12
  • Glad to see this worked in your case! I have expanded it into an answer. Regarding the font, no Vim can't really control that, it's a property of the terminal and you need to configure it there instead, Vim (in the terminal) will simply use whatever font is configured in the terminal. – filbranden Oct 26 '19 at 9:15
  • Re: font. Those screenshots are from the graphical version of NVIM (NeoVim), the similar one from Vim is probably MacVim on the Mac. So in that case the font is picked inside Vim (with the set guifont option, see :help 'guifont'), but that doesn't help you much, since the font is not included in the colorscheme (which is strictly about colors) so you'd need to know which font the author used and, if you knew that, you could just as well use it on your terminal... Consider contacting the author (somehow?) to ask about which font that is? – filbranden Oct 26 '19 at 9:23
0

In short, include this line in your Vimrc:

set termguicolors

The theme's README file indicates you need that to enable "true color" support. (The snippet over there is a bit more complicated, to also cope with early NeoVim releases and to check that the option is available in your Vim, you can probably skip that and just set it directly.)

It also mentions the theme is able to gracefully downgrade if True Color support is not enabled/available, in which case the final result will likely depend on quite a few other settings of your terminal, such as whether you're using a 256-color enabled $TERM and, if not, what the 16-color pallete is in use on your terminal. (Unfortunately, this gets pretty complex very quickly.)

True Colors means using 24-bit values for RGB colors (one 8-bit byte per component), which needs to be supported by your terminal. You can read more starting at :help xterm-true-color but, again, it tends to go into the complex details of Terminal implementations, so maybe it won't help you too much there either.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.