2

I'm testing neovim and for many thing it is working way faster than vim (I use many plugins ~80, and I can really tell the difference with neovim). All the same config files worked out of the box, but I've notice this different behavior. hlsearch seems not to be working, it does work when I use / but not when I use :g or :%s. Here an example, neovim on the left, vim on the right:

enter image description here

As it can be observed, in vim the pattern is highlighted which is great. Is there a way to activate this behavior in neovim or is this feature missing?

  • It shouldn't work with :g in either nvim or vim, but in my system, I do get highlighting for :s... Have you tried :set hlsearch with :set incsearch in a default system (without config)? – klaus Oct 23 '19 at 10:34
  • @klaus why shouldn't it work? it's a great feature hehe – Blasco Oct 23 '19 at 10:46
  • I'm my vim it works with both :g and :s – Blasco Oct 23 '19 at 10:47
  • 2
    I believe you need incsearch to enable live highlighting when entering the search pattern using :g and :s. The incsearch feature for :g and :s is a relative recent Vim addition, needs at least 8.1.0271 (and several patches after that). Most likely neovim hasn't included that one yet. – Christian Brabandt Oct 23 '19 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.