1

I upgraded MacVim to 8.1.2168 (159) tonight and now the vimwiki files in Markdown format do not highlight correctly when I enable spell check.

I run set spell spelllang=en_ca as I have before. It looks almost like the spell check is finding all of the first word except the first character in some (but not all!) of the sentences, and reporting those fractions of words as misspellings.

incorrect spell error hightlight

I believe this is some sort of new conflict between the vimwiki files in Markdown format and the new upgraded version of vim and spellcapcheck

Abridged output from set:

 syntax=vimwiki      
 filetype=vimwiki    
 spell  
 spellcapcheck=[.?!]_[])'
 spellfile=~/.vim/spell/en.utf-8.add
 suffixesadd=.markd

I can see that the default string for spellcapcheck is default "[.?!]\_[\])'"' \t]\+" while mine is [.?!]_[])'. Yet I run

set spc="[.?!]\_[\])'"' \t]\+"

and the highlighting does not change.

When I run set list I can see that there is an eol at the end of each line. This is as I expect.

It is not lost on me that the first word of each sentence is not highlighted if the remaining characters after the first character form a valid word:

  • David does not appear as a highlighted spelling error because avid is a valid word.
  • Daphne appears as a highlighted spelling error because aphne is a typo.

Where do I look next to fix this?


  • I honestly cannot reproduce this with spelllang=en_ca and spellcapcheck=[.?!]_[])' on terminal vim 8.1.1850. Is it only vimwiki files that do this? – D. Ben Knoble Oct 21 at 23:36
  • The command you used to try to reset 'spellcapcheck' to its default isn't correct (See :help option-backslash and note that you shouldn't be including the surrounding quotes that are mentioned in the documentation for :help 'spc'.) Having said that, I can't reproduce your issue either. Does running :set spc& affect the problem? – Rich Oct 22 at 9:23
2

This is a known bug, introduced by patch v8.1.2153 that has since been fixed with patch v8.1.2172, so you'd need to update your MacVim to a new Version.

  • I confirm that the problem is no longer present after I updated MacVim to 8.1.2224. Thanks! – StandardEyre Oct 29 at 16:17
1

I am having the same issue. Just upgraded to 8.1.2168 a couple days ago. A couple things I noticed:

  • My default spellcapcheck was set to [.?!]\_[\])'"^I ]\+, changing it to yours ([.?!]_[])') or [.?!]\_[\])'"' \t]\+ had no effect.
  • Perhaps more interestingly, it doesn't appear that these are actually recognized as typos: when I use ]s and [s to move to misspelled words, vim skips over the words at the start of lines (unless they are explicitly misspelled).

In other words, looks like gvim doesn't actually think these are misspelled words, but erroneously highlights them anyways.

I tested this by opening up an empty file (vim -u NONE), running set spell, typing some words (some purposefully misspelled), observing what was highlighted, and using ]s & [s to see what was actually flagged as misspelled.

  • 1
    Welcome to Vi and Vim! This is fascinatingly useful information for the question, but doesn't really answer it. It might be better as a comment on the question, or an edit to add more information. – D. Ben Knoble Oct 22 at 16:41
  • @D.BenKnoble I 100% agree. Unfortunately, since I am a new member, I am actually unable to add comments until I have a reputation of 15. I wanted to add a comment initially because I did not have a direct answer :( (Edit: Actually I need a reputation of 50 to post comments on other people's questions/answers) – Ryan Sheatsley Oct 23 at 14:00
  • @D.BenKnoble also thank you for the information. What would you recommend to be the correct course of action in this situation? I'd like to follow the rules and recommendations diligently. – Ryan Sheatsley Oct 23 at 14:08
  • I'm honestly not sure. You could put up a custom flag for a moderator to ask, or ask on Vi and Vim Meta – D. Ben Knoble Oct 23 at 14:20
  • Thanks for your help! – Ryan Sheatsley Oct 23 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.