0

I create a session using :mks, which has tabs and split views inside tabs. When I open the session using vi -S Session.vim, some of the files are swapped around. I have tried deleting and creating new session files, but to no good. It behaves reproducibly. If I create a session with an identical arrangement of files in tabs and splits, it swaps the same files in the same way. If I intentionally swap the files to get the desired outcome, I get the right outcomes for the two tabs among which the original swap occurred, but other files swap. It is mysterious and very annoying. Any ideas what may be wrong?

Using vim -S instead of vi -S does not make any difference.

This happens on a work computer, where I have only a pseudo-sudo access. (can install new software only from existing repositories) Therefore, I cannot install ViM 8, which has not been uploaded to the Ubuntu repository yet. I will try to reproduce this on my personal computer and see if updating ViM helps.

I am using:

VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Jun 07 2019 15:35:43)

(2:7.4.1689-3ubuntu1.3)

Edit: I have managed to reproduce it on my personal computer and after updating to ViM 8 the problem disappeared. There is not much point in seeking solution for older versions, so let's consider this question solved.

  • Welcome to Vi and Vim! Does this happen if you use vim -S instead of vi -S? Does this happen if you use vim 8? Feel free to edit to clarify – D. Ben Knoble Oct 16 '19 at 14:30
0

The solution is updating to ViM 8.

| improve this answer | |
  • Glad you resolved your problem. I will always wonder what caused this though... – D. Ben Knoble Oct 17 '19 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.