2

The address is ftp://ftp.yandex.ru/

I tried from bash: vim ftp://ftp.yandex.ru/

After that I was asked for username and password (but this is public anonymous server), ok I entered anonymous for username and password. I tried to "enter" empty username and password also. I see this:

" ============================================================================
" Netrw Directory Listing                                        (netrw v156)
"   ftp://ftp.yandex.ru/
"   Sorted by      name
"   Sort sequence: [\/]$,\<core\%(\.\d\+\)\=\>,\.h$,\.c$,\.cpp$,\~\=\*$,*,\.o$,\.obj$,\.info$,\.swp$,\.bak$,\~$
"   Quick Help: <F1>:help  -:go up dir  D:delete  R:rename  s:sort-by  x:special
" ==============================================================================
../
./

Vim 8 from default repository on Xubuntu 18.04.3 LTS.

5
  • anonymous for username and password works for me (Vim 8, Ubuntu 18.04.3) – muru Oct 16 '19 at 9:59
  • @muru trued again - the same empty screen of explorer. – Vitaly Zdanevich Oct 16 '19 at 10:58
  • Does your network block access to that site or to FTP? Can you access it using the command-line ftp client, or a browser? – muru Oct 16 '19 at 10:59
  • @muru I can open this link in Firefox. – Vitaly Zdanevich Oct 16 '19 at 21:16
  • As well as seeing the behaviour you describe, netrw also opens a split window containing a NetrwMessage buffer with the contents: **error** (netrw) this system doesn't support remote directory listing via ftp ...which clearly isn't true. – Rich Oct 17 '19 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.