1

I use Vrapper, which is a great plugin, providing some vim emulation to Eclipse.

One of the features of Vrapper is that from anywhere you can type :vim and it will reopen the file you are currently editing into gvim. (This is quite useful when you want to use the full power of Vim from Eclipse.)

Users provide the path to a gvim executable to the plugin through a _vrapperrc file.

Currently, if I set the path as follows, it works (with gvim)

set gvimpath="C:\Program Files (x86)\Vim\vim81\gvim.exe"

However, I also use nvim-qt, and the following setup doesn't work:

set gvimpath="C:\Users\blah\Documents\tools\nvim\Neovim\bin\nvim-qt.exe"

I am on the last vrapper stable version.

It might be a vrapper bug, but I am posting hoping someone has a similar setup and solved the issue.

  • 2
    I think the problem is the option gvimargs. The default value is for gvim, but it seems nvim-qt needs different arguments. I have no experience with nvim-qt, but I guess you have to add a leading -- (thats dash-dash-space) before the current value of gvimargs. – Ralf Oct 4 at 13:19
  • @Ralf: Thanks, you are onto something, I modified gvimargs, and it now launches nvim, with no file currently, but that is still progress. I will try to find the correct gvimargs and post it – Xavier T. Oct 4 at 14:54
1

Ralf had the correct intuition regarding the other parameter gvimargs.

This does not work with nvim-qt. If you to pass argument from "nvim-qt" to the neovim implementation you have to separate them by a double dash.

This is specific to nvim-qt, nvim in the terminal works both with and without double dash.

I ended up putting in my _vrapperrc

set gvimargs=-- +{line} -c "normal zv{col}|" -c "set nobackup" -f -n {file} 

And it works correctly with NVIM 0.4.2 and Vrapper 0.74.0 on Win10.

For reference, according to the documentation of vrapper, the default value of gvimargs is

 gvimargs=+{line} -c normal zv{col}| -c set nobackup -f -n {file}
  • Have you tried gvimargs=-- +{line} -c normal zv{col}| -c set nobackup -f -n {file}? See here or here. – Ralf Oct 5 at 16:34
  • Corrected quoting: Try set gvimargs=-- +{line} -c "normal zv{col}|" -c "set nobackup" -f -n {file} – Ralf Oct 6 at 6:35
  • This works as well, and additionally preserve the column, I will update my answer. – Xavier T. Oct 7 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.