2

please be gentle, I am trying to learn neovim, coming from vim

the command :!top executed inside neovim returns

top: failed tty get

shell returned 1

After googling, only search results from fzf github regarding kernel regression

https://github.com/junegunn/fzf/issues/1486

https://github.com/junegunn/fzf/issues/447

I have never used fzf in vim/linux before, I am also trying to use it later on in neovim

But trying out the command on fzf (after installing it), from 1486

echo "hello" | fzf --preview 'echo {}'

in the terminal, it does not return any error. So I think the kernel regression issue is solved?

The OS I am using is Debian Buster.

I am not using :terminal or Ctrl-Z to use shell commands in my vim workflow.

If you find that the only way to use these programs is to use these two options in neovim, please let me know.

1

Have a look at :help :!. It says:

The command runs in a non-interactive shell connected to a pipe (not a terminal). Use :terminal to run an interactive shell connected to a terminal.

As top requires a terminal, it can't be run this way.

Running :!top in Vim works as expected, so :! seems to be implemented differently in neovim.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.