1

Iam trying to put nnoremap <C-Right> <C-w>3> in the ~/.vimrc

But it's not working. Also, VIM has a PRETTY ANNOYING line erasing binding to ctrl+Right in the Normal Mode. I would like to deactivate this erasing and do split resize with Ctrl + Arrows.

How is the most secure way to config this ?

thank you

  • 1
    The mapping works for me. It should work for you too. Try to check if some other keybinding is clashing with it or maybe there is some error in the vimrc – klaus Sep 13 at 21:31
  • 1
    Also, VIM has a PRETTY ANNOYING line erasing binding to ctrl+Right This is not the default setting. Check your terminal setup. – Matt Sep 14 at 5:25
  • Ctrl keys are difficult to bind; not all terminals allow all keys to be bound (eg on mac its impossible because C-right is an OS level key) – D. Ben Knoble Sep 14 at 12:52
  • @klaus "Try to check if some other keybinding is clashing" and @Matt "Check your terminal setup", you mean in the vim .vimrc file ? – Syncaa Sep 14 at 13:48
  • Execute :verb nmap <C-Right> to find out if and where a mapping for Ctrl+Right is defined. – Jürgen Krämer Sep 17 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.