2

When I use Vim on my home Ubuntu computer, I am able to use alt-[key] as a quick way to jump from insert mode to normal mode and immediately run the [key] command. One thing I frequently do is: alt-j or alt-k from insert mode, where it immediately jumps up or down in normal mode. Unfortunately on mac iterm2, using alt-j does nothing and option-j likewise simply adds the ' character. How can I edit this to use option/alt in the same way?

  • Welcome to Vi and Vim! I suspect this is a « feature » of iterm2 (normally the alt keys send escape and then a key code). I expect answers will tell you to toggle a pref in iterm2 – D. Ben Knoble Sep 5 at 0:51
  • This is an iTerm configuration issue. See this post about handling of the Meta key, you probably want ESC+. – filbranden Sep 5 at 2:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.