1

Good afternoon,

I just started using the Ubuntu shell from Windows 10, and I copied my Mac .vimrc file. Everything seemed normal until these yellow bars started showing up at the end of some lines. It doesn't seem to be search syntax highlighting. I used :nohl command but that doesn't seem to work. It goes away if I manually highlight the lines and yank them, I would not like to do that every time I want to edit files.

Here is what it looks like: Screenshot of vim

.vimrc file:

set shiftwidth=4
set tabstop=4
set softtabstop=4
set autoindent

"autocmd FileType html setlocal shiftwidth=2 tabstop=2
"autocmd FileType php setlocal shiftwidth=4 tabstop=4
"autocmd FileType javascript setlocal shiftwidth=4 tabstop=4

set lbr
set tw=500
set ai
set si
set wrap
set t_Co=256
set number
set mouse=
"ar mousemodel=extend
"set clipboard=unnamedplus
set background=dark
syntax on
"let g:onedark_termcolors=16
set noshowmatch
map <F6> :next<CR>
map <F5> :previous<CR>
set formatoptions=r
call plug#begin('~/.vim/plugged')
    Plug 'jwalton512/vim-blade'
    Plug 'maslaral/the-creator.vim'
    "Plug 'liuchengxu/space-vim-theme'
    Plug 'sainnhe/edge'
call plug#end()
"colorscheme space_vim_theme
"colorscheme the-creator
colorscheme edge
  • 1
    Out of curiosity, what version of vim is installed in the Win/Ubuntu distro? (Or is it bring-your-own....?) – B Layer Sep 4 at 1:07
  • 1
    Dont set t_Co manually, please. – D. Ben Knoble Sep 4 at 3:24
  • @D.BenKnoble . That may be overstating it. There are scenarios where it's desirable or even necessary to set t_Co. Some examples are in vim's documentation. Setting it globally, otoh, is not kosher. It should be inside a system-level conditional block or the like. – B Layer Sep 5 at 9:17
  • 1
    @BLayer vim --version says 8.0 – novoalg Sep 5 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.