1

Since ever in my configuration of vim text and markdown-files are indented on following lines to align with open parenthesis.

Text Text Text (e.g. Hello
                World)
More Text

This happens when I create a new-line by line-breaking or when I run gg=G.

How do I disable this for these Filetypes?

I tried disabling autoindent, smartindent, ain't working.

  • 1
    What's the output of :verbose set cindent? And how about :verbose set indentexpr? – Rich Sep 2 at 14:35
  • 1
    For all these years I thought that cindent is automagically only applied to C/C++ filetypes, but it is applied to every ft if put in .vimrc as it is my case. – Patrick B. Sep 2 at 15:58
3

As discussed in the comments, this behaviour is caused by cindent.

You can check what's setting this with the command:

:verbose set cindent?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.