0

Vim error detected

Everytime i quit the vim i got this error, it's just pop up in a second. I already upgrade the vim to the latest version but still got the same error.. How to fix that?

The error message reads:

Error detected while processing function unite#sources#mru#_save[7]..218[7]..219[24]..220:
line    1:
E892: Using a String as a Float
0

The error message you're seeing refers to a function in the unite#sources#mru namespace, which means it's probably in a MRU plug-in for unite.vim, most probably neomru.vim.

There's an issue reported there that is very similar to yours: issue #48: "Vim error: using String as a Float", reporting code that works in NeoVim but breaks in Vim 8.1. That issue was fixed by this commit, around 5 months ago.

So, try updating your plug-ins and see if that fixes that issue?

If it doesn't, see if these are indeed the plug-ins you have and try to disable them to confirm whether that solves your issue or not.

If you don't really use those plug-ins (and just got them from copying and pasting from somewhere in the web into your vimrc), consider disabling/removing them, no point in keeping them around if you don't use them...

If you still can't figure it out, you need to post a more detailed question, including more information about your system, which plug-in manager you're using (if any), which plug-ins you have installed, perhaps relevant snippets from your vimrc, etc.

  • I tried to remove unite plugin on .vim dir and it's solved the problem. But i still don't know if there's a unite plugin left somewhere since i don't know how that plugin is installed. The plugin comes along with the OS. I'm using NeoBundle – Randi Aug 10 at 13:40
  • If removing it from .vim solved the problem, then it sounds like you got your answer, right? Was there something else you wanted to get accomplished here? – filbranden Aug 10 at 17:07
  • I thought unite was deprecated anyway, for denite? Maybe im wrong. – D. Ben Knoble Aug 10 at 18:24
  • “Comes along with the OS” huh @Randi ? – D. Ben Knoble Aug 10 at 18:25
  • The plugin is pre-installed @D. Ben Knoble – Randi Aug 10 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.