4

How can I make it so that no command or extra keystroke is required for the autocompletion menu to pop up?

i.e. what I want is the menu to be always present while in insert mode and to be constantly updating its suggestions as I type.

  • 1
    Supertab is not an auto-completion plugin. Which auto-completion plugin are you using? – jdhao Aug 7 at 5:16
  • Well none, then. I mean the usual Ctrl-n type menu. – salonkommunist Aug 7 at 5:27
  • I found this solution, which seems to (kind of) work for me, see the link below. However, the noinsert/noselect options do not seem to have any effect, why is that? (I can't comment there for lack of rep :/ ) vi.stackexchange.com/questions/15733/… – salonkommunist Aug 7 at 14:02
  • You can use set completeopt? to see if this option is correctly set. Some other plugins or settings may override this option – jdhao Aug 8 at 1:57
1

If you're looking for a super simple solution, you can add the code from this page to your .vimrc. https://gist.github.com/maxboisvert/a63e96a67d0a83d71e9f49af73e71d93

There is also a plugin version of it which can be found here. https://github.com/maxboisvert/vim-simple-complete

0

I'm personally using https://github.com/maralla/completor.vim for this, it's very lightweight and requires no configuration to work. It doesn't do any fancy stuff or alter what's shown in the completion pop-up in any way, it will simply auto show the completion pop-up whenever it can.

I'm also using these settings for it, to make it more ergonomical:

" Select autocomplete item with Tab
inoremap <expr> <Tab> pumvisible() ? "\<C-Y>" : "\<Tab>"

" Don't autoselect an item from the completion menu, and always show the menu
let g:completor_complete_options='menuone,noinsert'

" No delay on showing the completion pop-up
let g:completor_completion_delay=0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.