0

When I press C-o in insert mode, the expected behaviour is that vim will wait for me to execute a single command and then returns to insert mode. Usually, after pressing C-o I have all the time in the world to enter the command. However, with my current setup the temporary normal mode triggered by C-o only lasts for a second and then falls back to regular insert mode. I have narrowed the problem down to the coc.vim plugin so it probably has to do with how autocompletion works. Could there be, for instance, an option to increase the time vim waits before returning back to insert mode?

  • 1
    Maybe an InsertLeave autocommand? You could set 'verbosefile' to something then :set verbose=9. Reproduce the problem and check whether there are any clues in the file you specified. If not bump up 'verbose' to 12 and try again. – B Layer Jul 13 at 3:17
  • I think you're right. By scanning a verbosefile I did find an InsetLeave autocommand: Executing InsertLeave Autocommands for "*" autocommand call s:Autocmd('InsertLeave', +expand('<abuf>')) – jharme Jul 13 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.