0

I, I'm trying to to install vim to use as a Python IDE on arch.

I was using this tutorial to do it, but ran into some troubles. When I tried to open vim I got the following error messages:

https://pastebin.com/055MedL9

I had earlier tried to install pyflakes through it, but got a very similar type of errors messaging when I tried to install it thorough the Github Vundle tutorial page. This was my second try. This time I tried to install through the above mentioned tutorial, resulting in error, as in the first attempt. The second attempt produced less error messages, but it had much less code, so they probably were as wrong as each other.

In both cases if I ignored the error messages and entered the vim session, if I wrote "PluginInstall", I received the following error message:

"E492: Not and Editor Command: PluginInstall"

This my vimrc: https://pastebin.com/hP0DaVR1

and this is the tree of my .vim folder: https://pastebin.com/kpgP8sxM

I am sorry for using pastebin for my documents but I had a lot of difficulties with the formattting from the site. I tried it in 3 different browsers and couldn't make it work.

Any help would be greatly appreaciated.

EDIT 1: Hi, I changed the line to set rtp+=~/.vim/bundle/autoload/vundle, as per Statox suggestion, and after sourcing vimrc, I get these error messages:.vimrc:1: no such file or directory: https://github.com/VundleVim/Vundle.vim\nset nocompatible
.vimrc:3: command not found: filetype .vimrc:11: no such file or directory: let Vundle manage Vundle, required\nPlugin 'VundleVim/Vundle.vim'\n\n .vimrc:15: no such file or directory: Keep Plugin commands between vundle#begin/end.\n .vimrc:17: command not found: Plugin .vimrc:18: no such file or directory: plugin from http://vim-scripts.org/vim/scripts.html\n .vimrc:20: unknown file attribute: i .vimrc:23: command not found: Plugin .vimrc:24: command not found: The sparkup vim script is in a subdirectory of this repo called vim.\n .vimrc:26: parse error near `}'

  • 1
    I haven't used Vundle in a long time but in your vimrc you have set rtp+=~/.vim/bundle/Vundle.vim where as it seems that your vundle.vim is in bundle/autoload/ so to debug your issue I would start here: Are you sure all of your files are where they are supposed to be? – statox Jun 17 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.