1

Running :checkhealth in NeoVim-Qt (v0.3.5) I get the following report on terminal:

ERROR: command failed: infocmp -L
infocmp: environment variable TERM not set

How can I set the environment variable TERM in NeoVim-Qt?

2

The TERM environment variable is generally set by the terminal emulator you're running in, and it tells programs using curses (like Vim and Neovim) what sequences to send to the screen to do things like moving the cursor and setting colors. When you're using a graphical environment, Vim and Neovim don't need this environment variable to be set, since they're not drawing on a terminal, but instead in a graphical window.

If you're invoking Neovim-Qt from a terminal, then this environment variable will be set, but otherwise it generally will not be, and that's not a problem. Neovim warns you about this in :checkhealth because for terminals, not setting it usually leads to problems; they appear not to have considered the GUI case. You can just ignore this error, since it's harmless for GUIs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.