2
  1. Suppose I run

    :terminal someprg_wide_output

the output is wrapped by current termnal window size wrapped hard way, so :set nowrap there can't help

  1. When I run same prog not from vim like this

    someprg_wide_output | vim -

vim accepts the whole width of the output without wrapping lines

I tried adding ++cols option, it does not seem to work as expected

:terminal ++cols=300 someprg_wide_output

Is there a way to make vim terminal think it is wider as visible part? I would like output looks in 1. like it does for 2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.