1

I ran PlugUpdate recently and somehow all the Ale linter errors started popping up right in the buffer at the end of the line. It used to just put signs on the left side for the problematic line and put all the actual errors in the quickfix and display them in the status bar when cursor is on the line. How do I turn these inline errors off?

Here are relevant bits and pieces of my init.vim (using neovim)

Plug 'autozimu/LanguageClient-neovim', { 'branch': 'next', 'do': 'bash install.sh', }
Plug 'Shougo/deoplete.nvim', { 'do': ':UpdateRemotePlugins' }
Plug 'lighttiger2505/deoplete-vim-lsp'
Plug 'w0rp/ale'

" language client
let g:LanguageClient_serverCommands = {
    \ 'haskell': ['hie', '--lsp'],
    \ 'c': ['ccls', '--log-file=/tmp/ccls.log'],
    \ 'cpp': ['ccls', '--log-file=/tmp/ccls.log'],
    \ 'python': ['pyls', '--log-file=/tmp/pyls.log'],
    \ }

" deoplete
let g:deoplete#enable_at_startup = 1
let g:deoplete_disable_auto_complete=1
call deoplete#custom#buffer_option('auto_complete', v:false)
autocmd InsertLeave,CompleteDone * if pumvisible() == 0 | pclose | endif
inoremap <expr><tab> pumvisible() ? "\<c-n>" : "\<tab>"

let g:deoplete#sources = {}
let g:deoplete#sources.cpp = ['LanguageClient']
let g:deoplete#sources.python = ['LanguageClient']
let g:deoplete#sources.python3 = ['LanguageClient']
let g:deoplete#sources.rust = ['LanguageClient']
let g:deoplete#sources.c = ['LanguageClient']
let g:deoplete#sources.vim = ['vim']

" ale
let g:ale_sign_column_always = 0
let g:ale_emit_conflict_warnings = 0
let g:ale_lint_on_text_changed = 'never'
let g:ale_set_loclist = 0
let g:ale_set_quickfix = 1
3

Found it. Turns out it was not Ale doing it, but rather LanguageClient-neovim. The setting to turn it off is

let g:LanguageClient_useVirtualText = 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.