0

For practicing in vim I made:

$ man bash > PracticeFile

but upon setting up line numbers, using:

:set nu

the formatting got messed up, so that letters at the end of line are closer to number than the numbers are to remaining of text. Is there any way to make line number not interfere with the formatting of the text?

Edit: A screenshot enter image description here

2
  • can you provide a screenshot please? – padawin May 21 '19 at 15:04
  • Btw, try :help :Man ;) – D. Ben Knoble May 21 '19 at 16:18
1

Your lines are just wrapped. To stay in the screen.

If you don't want them wrapped, run:

:set nowrap

For more information, look at:

:help wrap
3
  • So there is no other way? some of the text is lost by setting :set nowrap – pigeon May 21 '19 at 15:27
  • What kind of "other way" (other result?) do you think about? It is not lost, you can bring your cursor to the end of the line and the view will scroll to see the right part. – padawin May 21 '19 at 15:31
  • You are right, that made the trick. I was worried because i am using non GUI tty terminal. Thanks a lot. – pigeon May 21 '19 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.