2

I am a user of neomutt and I use neovim as my default editor.

However, when I delete a character via backspace, and then type the correct character, I sometimes get a strange character from a different language. To give an example, If have have the word "coe", and I want to change "e" to "d", then I naturally would press backspace and then "d". However, that inserts "coで".

I am running into this problem only when I run neovim though neomutt. When I run vim regularly, I don't encounter this issue.

Any idea what could cause this issue? I am a mac user.

  • 1
    Thats a digraph. I know it can be triggered in this way but there’s a way to turn that off – D. Ben Knoble May 13 '19 at 7:55
  • I'm not familiar with neomutt but if the problem only happens in neomutt then I think it is not a problem related to neovim which would make this question off topic. You should ask in their issue tracker: github.com/neomutt/neomutt/issues. EDIT Ben might be right, using set nodigraph might solve the problem (See :h i_digraph) – statox May 13 '19 at 7:55
1

As @D.BenKnoble and @statox have mentioned, this sounds like you have the 'digraph' option set in Neovim but not in Vim.

Running :set nodigraph in a running instance of Neovim should fix the problem, and you can run :verbose set digraph? to find out what part of your configuration is setting this option so you can resolve the issue properly.

See :help i_digraph and :help 'digraph' for more details.

  • Thank you very much. And you were right. It was related to the digraph value set in vim. – Husain May 13 '19 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.