0

Using vim 8.*, I am using these plugins: html5.vim polymer-ide.vim supertab vim-javascript

In my vimrc.local file if I enable filetype plugin indent on it breaks my javaScript indention but makes the highlighting correct. However, if I remove that line then my indention works as it should for javaScript but the highlighting breaks.

How can I have both the highlighting and indention working?

closed as unclear what you're asking by D. Ben Knoble, Herb Wolfe, jamessan, Martin Tournoij May 3 at 3:25

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    What do you mean vimrc.local file? Are you using some kind of distribution, or vanilla vim? If the plugins are structured correctly, turning indent on should be fine. Highlighting is controlled by the syntax command. Wdym by indentation/highlighting breaks/is correct ? – D. Ben Knoble May 1 at 14:49
  • 2
    Until the question has more detail, I’m voting to close it as unclear. Try debugging your vimrc, and eliminating plugins, and see if you can narrow down on the details of your problem. – D. Ben Knoble May 1 at 14:50
  • 1
1

What if you just enable the filetype plugin?

filetype plugin on

Not the answer you're looking for? Browse other questions tagged or ask your own question.