1

When using vim's help I can jump to multi-word tags, but when creating my own tags Ctrl-] tries to match individual words. Consider the following example:

file.txt

|a-tag|
*a-tag*

When pressing Ctrl-[ over "a" it tries to match "a" and not "a-tag". Similarly, if the cursor is on top of "tag" vim searches for "tag" only. When visually selecting "a-tag" it works.

The tags file is the following:

tags

a-tag file.txt /*a-tag*

How do I change Ctrl-] behavior to search for the whole WORD inside |a-tag|?

  • Have you tried setting the filetype to help? – D. Ben Knoble Apr 17 at 23:27
  • Check your iskeyword setting. Vims help file use a custom iskeyword setting, as can be seen by :verbose set isk? – Christian Brabandt Apr 18 at 5:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.