1

I am a complete vim noob, that tries to get some Snippets with UltiSnips running. My minimal .vimrc is:

syntax on

call plug#begin('~/.vim/plugged')
Plug 'lervag/vimtex'
let g:tex_flavor='latex'
let g:vimtex_view_method='zathura'
let g:vimtex_quickfix_mode=0
set conceallevel=1
let g:tex_conceal='abdmg'
Plug 'SirVer/ultisnips'
let g:UltiSnipsExpandTrigger='<tab>'
let g:UltiSnipsJumpForwardTrigger='<tab>'
let g:UltiSnipsJumpBackwardTrigger='<s-tab>'
let g:UltiSnipsEditSplit='vertical'
Plug 'honza/vim-snippets'
call plug#end()

The preinstalled Snippets worked in :UtilsSnipetEdits. My own Snipets didn't work in my texfile. An example out of my tex Snipets is:

snippet beg "begin{} / end{}" bA
\begin{$1}
    $0
\end{$1}
endsnippet

I just tried to delete everything i used before (e.g. YouCompleteMe). Do you have some advice for trouble shooting?

closed as off-topic by statox Apr 7 at 17:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question was caused by a problem that can no longer be reproduced or a simple typographical error. While similar questions may be on-topic here, this one was resolved in a manner unlikely to help future readers." – statox
If this question can be reworded to fit the rules in the help center, please edit the question.

  • First of all, remove everything that is not plugin call from in between plug#begin() and plug#end(). Those are supposed to be calls for plugin and updating :h rtp. Move everything else to somewhere else in your vimrc. Then read about directories where snippets are searched in. And then read how the snippets are loaded. – klaus Apr 5 at 18:47
  • Please add the full path where you have saved your own snippet beg. – Hotschke Apr 5 at 19:11
  • Possible location could be ~/.vim/UltiSnips/tex.snippets. – Hotschke Apr 5 at 19:13
  • Thanks for your fast response. I placed the calls outside. My Snipets are in "~/UltiSnips/tex.snippets" (afaik default). I created them over the command ":UltiSnipsEdit" in a tex-file. – Timothy_MIPS Apr 5 at 19:44
  • I added the line set runtimepath+=~/ultisnips but it still just tabs away :( – Timothy_MIPS Apr 5 at 20:01

Browse other questions tagged or ask your own question.