0

I didn't know what is the best title for this question. This problem is annoying me so much.

I'm on Windows 7 and using nvim-qt.

When I search for a word in the project or for example open NERDTree and expand a directory, Vim selects the right most window. But it doesn't select the words themselves, however, it selects everything else.

Here is a screenshot:screenshot

I thought this is a theme probelm, but I changed it and the problem remains. I was using vim-one and now solarized.

I also disabled using mouse using set mouse= but not working.

The only way I know to remove this highlighting or selection is to move with the cursor over all the selected lines and doing this, the selection is removed.

If I enabled color column (say 80), the highlighting is only applied for the right side of the column. Check this screenshot:

enter image description here

Does anyone has an idea what is this and how to solve it?

  • Try using nvim-qt without 3rd party colorscheme and see if the problem is with neovim-qt itself, first. On second thought, you should launch it with -u NORC option to disregard your config file and check if your config has any problem or if the installed nvim-qt is the culprit itself. My guess is you need to set up the background of the theme yourself and that is why the themes aren't working. – klaus Mar 29 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.