0

I have the ale linter installed. it works fine for my php files but for some reason when I started doing typescript, it keeps on giving me these error

enter image description here

with the error message

indent: space indentation expected

I tried all the options listed in the ale docs, but the only thing that seems to work is when i just shut it off entirely by putting this in my vimrc:

let g:ale_linters_explicit = 1

How can I do one of the following two:

1) turn it on just for php (I tried doing this but it didn't work:

let g:ale_linters = {
\   'php': ['eslint'],
\}

2) make it actually work for typescript without all these errors (it seems all the files are full of errors)

1

1) didn't work because eslint is a typescript linter, you should pick a php linter.

2)indent is not a an error, take a look at ale option of your linter, it can be turned off most of the time.

  • How do I know what linter works for what language? – abbood Mar 24 at 21:23
  • @abbood :help ale – dedowsdi Mar 25 at 5:42
  • running that command gives me this: imgur.com/muIyTxu, which has nothing to do with ale. As a matter of fact i don't directly have ale installed as a plugin, i'm assuming it got included as an extension of one of my existing plugins. checkout my vimrc for reference. What am I missing? – abbood Mar 25 at 12:04
  • Why did you assume that? Uncomment ale plugin, install it and try everything again. – dedowsdi Mar 25 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.