0

I am using Vim 8.1 on Windows 10 and with a default package manager Vim doesn't see plugins in C:\Program Files (x86)\Vim\vimfiles\pack directory.

Did I put in into incorrect place?

EDIT:

It is the same configuration as I use on Ubuntu and it works there.

EDIT 2:

packpath=~/vimfiles,C:\Program Files (x86)\Vim/vimfiles,C:\Program Files (x86)
\Vim\vim81,C:\Program Files (x86)\Vim/vimfiles/after,~/vimfiles/after 
  • Check output of :set packpath?. This shows the directories where Vim searches for a pack subdir. – Ralf Feb 14 at 14:06
  • @Ralf Please take a look on edit. – Alex Feb 14 at 15:39
  • 2
    From packpath it seems ok. And below ...\vimfiles\pack you have <some-name>/start/<plugin-name>? – Ralf Feb 14 at 16:27
  • @Ralf I have the following structure : C:\Program Files (x86)\Vim\vimfiles\pack\bundle\start\<plugins directories> – Alex Feb 26 at 12:04
  • Alex, that looks good. I don't know what could be wrong. You could try to move the pack directory to ~/vimfiles. – Ralf Feb 26 at 12:40
0

Not sure if packages are being searched in $VIM/vimfiles directory.

Try

  1. if your HOME environment variable is not set, set it. (right click on Start button, select System, then Advanced system settings, then Environment Variables
  2. put your vimfiles directory to HOME

It works for me, settings and packages are loaded etc...

  • Setting HOME didn't help, unfortunately. – Alex Feb 14 at 11:33
0

Here is an example of how your directory structure below pack should look like:

pack
└── bundle
    ├── opt
    │   └── vim-fugitive
    │       ├── autoload
    │       ├── doc
    │       ├── ftdetect
    │       ├── plugin
    │       └── syntax
    └── start
        ├── ctrlp.vim
        │   ├── autoload
        │   │   └── ctrlp
        │   ├── doc
        │   └── plugin
        └── vim-commentary
            ├── doc
            └── plugin
  • Thanks, but I have the same on my linux machine and it works, so that's why I am surprised that on Windows it doesn't work. – Alex Feb 27 at 7:41
0

Well the problem initially was in the fact that due to some issues git repo files cloned in Ubuntu subsystem wasn't visible to Windows.

The second thing: paths should be HOME/vimfiles and HOME/.vimrc. At least this worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.