1

I have installed Vim-latex on my Mac. When I compiled my file, there seemed to be no error. Yet, when I pressed \lv, I got the following:

Error detected while processing function Tex_ViewLaTeX:
line   34:
E121: Undefined variable: s:viewer
E116: Invalid arguments for function strlen(s:viewer)
line   39:
E121: Undefined variable: appOpt
line   79:
E121: Undefined variable: execString
E116: Invalid arguments for function substitute(execString, '\V$*', mainfname, 'g')
line   80:
E121: Undefined variable: execString
E116: Invalid arguments for function Tex_Debug
line   82:
E121: Undefined variable: execString

Besides, for the sake of testing, I added an extra $ sign in my source file, but I got the same result as before when I pressed \ll. Thus, I guess the compilation was actually problematic. Does anyone know how to resolve this problem?

Any help will be greatly appreciated.

  • 1
    Maybe this issue that was recently fixed. – Ralf Feb 10 at 9:02
  • @Ralf it was fixed 1 year ago if I read right. OP would need a pretty old version of the plugin to get that error. Can OP confirm version/whether or not updating works. – D. Ben Knoble Feb 10 at 16:10
  • @D.BenKnoble Ahh - yes, it's 2019 now :-) – Ralf Feb 10 at 16:12
  • @Ralf ah so the commit actually is recent? The “about 1 year ago” tripped me up. I wish it would display the actual date. – D. Ben Knoble Feb 10 at 16:18
  • @D.BenKnoble No, I just saw Jan 31 and didn't check the year. But also the last official release on the github page is from 2018-01-12. As you said, the OP should use most recent version. – Ralf Feb 10 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.