1

Long time reader, first time poster.

I'm having an issue with ALE (asynchronous lint engine) -- be aware that I'm a second year student and relatively new to programming.

I really like this plugin. It is by far my most used vim plugin and it makes developing with a command line editor SO much more palatable.

Sometimes (relatively often in fact) it stops recognizing errors in a (seemingly random) file. This often coincides with a loss of syntax highlighting. The highlighting can be fixed with an easy :set syntax=cpp but no matter what I try I can't get the linter back. Literally the only thing that works is changing my directory name (and if I change it back it disappears again.

I've tried all the ale commands that look promising (ALEReset, ALEEnable, ALEResetBuffer, ALEFix, etc) but they don't do anything. I've also tried completely uninstalling and reinstalling the plugin.

Any pointers?

  • Loss of syntax highlighting? I guess this is when you open a new file or is it while you are editing the file? First you need a reproducable example and then you can debug your vimrc. – Ralf Feb 9 at 12:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.