0

This question already has an answer here:

I nearly always have a terminal window open when I'm doing extensive editing in Vim. I've used tnoremap to set mappings for the three heights I want the terminal window to be able to take.

Unfortunately, when splitting a window or quitting a window, Vim resizes all windows (effectively doing a ^W=). I want my terminal window to be exempt from all such resizing. If as a consequence all resizing except for adjusting the adjacent windows to close up the space is disabled, I can live with that.

How can I tell Vim to never resize my terminal window unless I explicitly request it? Better yet, in addition to my last question, is it possible to make my terminal window keep its size even when I issue ^W_?

marked as duplicate by B Layer, Herb Wolfe, Hotschke, Ralf, jamessan Jan 18 at 12:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

In researching something else, I stumbled across the answer to this question:

set noequalalways

Not the answer you're looking for? Browse other questions tagged or ask your own question.