0

I'm having trouble putting to words what I'm looking for, please mark as duplicate if appropriate

I have a key binding that launches a search based on a fuzzy finder (specifically bindings to fzf and fzf.vim for searching for files, based on this blog)

nmap ; :Buffers<CR>
nmap <Leader>t :Files<CR>
nmap <Leader>r :Tags<CR>

The trouble is, sometimes I press <Leader>t ... some search string, and the beginning of my search string is apparently a keybinding somewhere which is messing up my search. As a workaround, I press space as if it were part of the keybinding to start up the search, but that is not ideal.

Is it possible to disable all keybindings that start with <Leader>t or possibly tell vim to immediately execute the binding (greedily?) instead of waiting for more bindings?

  • Assuming your mapleader is backslash. What does :map \t print? – Ralf Jan 17 at 15:03
  • Thanks for the comment - I was able to find which plugins are populating my key mappings using :map \t, and disabled them accordingly like this – cbcoutinho Jan 17 at 15:13
  • Also try using nnoremap – D. Ben Knoble Jan 17 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.