0

I am compiling vim under Arch linux and it is failing the test "test_netbeans.vim" even though I did not ask for netbeans to be enabled for the build.

I tried editing the shared.vim file and removing the test files but it does not work because the compilation system apparently rewrites the test files every time it compiles.

How can I either ignore the test or delete it?

  • Is there maybe a flag to disable netbeans (during the configure step)? It may be enabled by default (?). – D. Ben Knoble Jan 11 at 15:20
1

I worked around this problem by using the compile switch:

--disable-netbeans

However, obviously it is just a workaround and the test failure will be a problem for anyone that wants to use netbeans with compiled vim.

  • I just compiled 8.1.722 on Ubuntu 16.04. Netbean integration is enabled by default. The test_netbeans.vim was run and OK. – Ralf Jan 11 at 16:00
  • Probably because it is Ubuntu. Arch has messed up python configuration and vim is not tested against Arch so its tests are broken on Arch. – Tyler Durden Jan 11 at 16:12

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.