0

I'm working long time with my own vimrc and lots of adjustments for different file types, ... in the macOS terminal (Vim 7.4.8056)and (the same config-files) on a rented Apache Server.

Now I just copied the .vimrc and my .vim-directory to a new Ubuntu-System (Vim 8). And it doesn't work. Just typing in vi returns lots of errors.

And the mysterious thing is that these errors don't make any sense for me. There are difficulties with:

  • syntax on
  • filetype plugin on
  • au BufNewFile,BufRead

All these commands are used in Vim 8, too. Do you have an idea what I can do to solve the problems instead of installing Vim 7? Or is there another configuration file working against mine?

Here you'll find the answers of Ralf's questions (I translated as best as possible from German to English):

  1. Does the same error occur if you start it as vim instead of vi? Answer: vim cannot be found
  2. What is the output of update-alternatives --display vi and update-alternatives --display vim? Answer: Best version of the link = /usr/bin/vim.tiny Link "links" at the moment to /usr/bin/vim.tiny Link vi is /usr/bin/vi /usr/bin/vim.tiny - priority 15
  3. The output of vim-version on Ubuntu? Answer: VIM - Vi IMproved 8.0 (2016 Sep 12, compiled Apr 10 2018 21:31:58)
  • 1
    Does the same error occur if you start it as vim instead of vi? – Ralf Jan 8 at 20:17
  • And what is the output of update-alternatives --display vi and update-alternatives --display vim? (You can skip the lines starting with "slave".) – Ralf Jan 8 at 20:23
  • Also important: The output of vim-version on Ubuntu. – Ralf Jan 8 at 21:55
  • @Ralf: Thank you for your questions. My answers you'll find above in some minutes. – TravelTrader Jan 9 at 13:29
  • Just realized: Could you fix the title of the question. It's about Vim7 on macOS and Vim 8 on Ubuntu. – Ralf Jan 10 at 9:36
0

On your Ubuntu system you have Vim installed in the "tiny" version. Vim can be compiled in different "sizes" from "tiny" to "huge". "Tiny" comes with a absolute minimum set of features, while "Huge" contains nearly everything. For example, the tiny build does not support syntax highlighting, hence the error on syntax on.

I would recommend to install the package "vim-gtk3". This is a "huge" build with all bells an whistles, including syntax highlighting, gui etc.

  • Great, Rolf! I've installed the package by sudo apt-get install vim-gtk3 and immediately all my configuration files are running without errors! I'm very happy!! Now I can start working with Ubuntu. Thank you very much! – TravelTrader Jan 9 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.