1

Whenever I write ];, in VIM-80 under Cygwin, these symbols get highlighted in yellow. This is a bit annoying and I want it removed.

Following the on-line help I found the file "usr_44.txt", regarding syntax highlighting. I tried the command :syntax clear, but no luck.

It may well be the case that this stems from me learning VIM, pressing keys frustrated while stuck in the editor. Anyway, how can I remove it ?

6
  • “Whenever”—all types of files, only c code, etc? The question is pretty unclear and could use more detail
    – D. Ben Knoble
    Commented Dec 28, 2018 at 18:34
  • Whenever - e.g. no filetype specified, so yes: all types of files. Sorry bout question being unclear. If I write "];", which I often do, particularly for c-files, then these keys gets highlighted in yellow
    – drC1Ron
    Commented Dec 28, 2018 at 18:41
  • Can you find out what syntax group they apply to or what highlight is “yellowing” them? Have you tried “nohlsearch” to turn off highlighting from the last search?
    – D. Ben Knoble
    Commented Dec 28, 2018 at 19:21
  • Could this be the matchparen that you're seeing? Commented Dec 28, 2018 at 23:24
  • 1
    @D. Ben Knoble - The "nohlsearch" did the trick. Thanks and happy new year. Cheers and greetings from the north
    – drC1Ron
    Commented Dec 29, 2018 at 18:58

1 Answer 1

1

As determined in the comments, ]; formed the last search pattern (as set by :global, :substitute, /, or ?—cf. :help quote_/), and 'hlsearch' was set.

Therefore, the characters were highlighted (usually a distinct yellow).

The solution to (temporarily) stop the highlight is :nohlsearch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.