0

I have a long data line:

enter image description here

When I switch off wrapping and place the cursor somewhere in the middle, it looks like this:

enter image description here

Here I see the "extends' listchar, but not the "precedes".

I also made the window smaller and larger (up to fullscreen), tried various intervals within the line, started vim with .vimrc and .vim/ removed, and used set listchars=precedes:a,extends:b: nothing revealed the missing "precedes" char.

Is this a bug or do I have to do more than setting the listchars?


(Debian 9.6, Vim 8.0)

2

The "extends" char is always visible when wrapping is off and there are additional chars to the right.

The other listchars (including "precedes") are only visible when the option list is set.

Don't know why.

  • Although the problem is not solved, I have marked your answer as "accepted", because I wanted to know, whether there is something wrong with my system, or it is a general bug. And a bug it is, for either should both characters being displayed without :set list, or none. I could file a bug report at Github, but with currently 600+ open issues I would rather wait until this number is down to 20 :-). – nst0022 Dec 28 '18 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.